SQL-инъекция в WHMCompleteSolution

Дата публикации:
09.10.2013
Дата изменения:
09.10.2013
Всего просмотров:
1085
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WHMCompleteSolution 5.x
WHMCS 5.x
Уязвимые версии: WHMCompleteSolution версии ранее 5.1.10 и 5.2.8

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных перед "AES_ENCRYPT". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.whmcs.com/

Решение: Установите версии 5.1.10 или 5.2.8 с сайта производителя.

Ссылки: http://blog.whmcs.com/?t=79427
http://localhost.re/p/whmcs-527-vulnerability

или введите имя

CAPTCHA