SQL-инъекция в OpenEMR

Дата публикации:
19.09.2013
Дата изменения:
19.09.2013
Всего просмотров:
2727
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenEMR 4.x
Уязвимые версии: OpenEMR 4.1.1 Patch 14

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP POST параметре "authProvider" в сценарии interface/main/main_screen.php когда "auth" равно "login" и "site" равно "default". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.oemr.org/

Решение: Установите версию 4.1.2 с сайта производителя.

Ссылки: http://www.exploit-db.com/exploits/28329/

или введите имя

CAPTCHA