Переполнение буфера в Squid

Дата публикации:
11.07.2013
Всего просмотров:
589
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2013-4115
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Squid 3.x
Уязвимые версии: Squid версии с 3.2 по 3.2.11 и с 3.3 по 3.3.6

Описание:
Удаленный пользователь может вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в функции "idnsALookup()" в файле dns_internal.cc при выполнении DNS запросов. Удаленный пользователь может с помощью специально сформированного запроса вызвать переполнение буфера.

URL производителя: http://www.squid-cache.org/

Решение: Установите версии 3.2.12 или 3.3.7 или исправление с сайта производителя.

Ссылки: http://www.squid-cache.org/Advisories/SQUID-2013_2.txt

или введите имя

CAPTCHA