Множественные уязвимости в Moodle

Дата публикации:
10.09.2013
Дата изменения:
10.09.2013
Всего просмотров:
3149
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Moodle 2.3.x
Moodle 2.4.x
Moodle 2.5.x
Уязвимые версии: Moodle версии 2.3.8, 2.4.5 и 2.5.1, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в "link" XML сущности при обработке внешних блогов. Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре импортированных данных.

2. Уязвимость существует из-за неизвестной ошибки. Подробности уязвимости не разглашаются.

URL производителя: moodle.org

Решение: Установите последнюю версию 2.3.9, 2.4.6 или 2.5.2 с сайта производителя.

Ссылки: http://docs.moodle.org/dev/Moodle_2.5.2_release_notes
http://docs.moodle.org/dev/Moodle_2.4.6_release_notes
http://docs.moodle.org/dev/Moodle_2.3.9_release_notes
http://makthepla.net/blog/=/moodle-2-account-takeover

или введите имя

CAPTCHA