Множественные уязвимости в WHMCompleteSolution

Дата публикации:
04.01.2013
Всего просмотров:
375
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WHMCompleteSolution 4.x
Уязвимые версии: WHMCompleteSolution версии ранее 4.5.3

Описание:
Уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и вызвать отказ в обслуживании приложения.

1. Уязвимость существует из-за ошибки при обработке PayPal транзакций в модуле paypal. Удаленный пользователь может зачислить средства на отличный настроенному в приложении PayPal аккаунту. Для успешной эксплуатации уязвимости модуль paypal должен быть включен.

2. Уязвимость существует из-за недостаточной обработки входных данных в модуле Google checkout. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости модуль Google checkout должен быть включен.

URL производителя: http://www.whmcs.com/index.php

Решение: Установите версию 4.5.3 или исправление с сайта производителя.

Ссылки: http://blog.whmcs.com/index.php?t=64778
http://forum.whmcs.com/showthread.php?64778-Security-Advisory-for-V4-5-amp-Google-Checkout-Users

или введите имя

CAPTCHA