Межсайтовый скриптинг в IBM TRIRIGA Application Platform

Дата публикации:
02.09.2013
Дата изменения:
02.09.2013
Всего просмотров:
900
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
CVE-2013-4003
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM TRIRIGA Application Platform 2.x
Уязвимые версии: IBM TRIRIGA Application Platform 2.1, 2.5, 2.6 и 2.7.

Описание:
Уязвимости позволяют удаленному пользователю произвести XSS нападение.

Уязвимости существуют из-за недостаточной обработки входных данных в нескольких параметрах в определённых сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Список затронутых параметров и сценариев:
http://[host]/WebProcess.srv
http://[host]/html/en/default/actionHandler/queryHandler.jsp
http://[host]/html/en/default/reportTemplate/hGridTopQuery.jsp?portalSectionId

URL производителя: http://www.ibm.com/support/entry/portal/overview//software/tivoli/ibm_tririga_application_platform

Решение: Установите обновление 3.3.1 и пакет исправлений 3.3.1.1 с сайта производителя.

Ссылки: https://www.ibm.com/support/docview.wss?uid=swg21646694
https://www.ibm.com/support/docview.wss?uid=swg24033723
https://www.ibm.com/connections/blogs/PSIRT/entry/security_bulletin_ ibm_tririga_application_platform_has_potential_cross_site_scripting_vulnerabilities_in_various_url_s

или введите имя

CAPTCHA