Множественные уязвимости в FFmpeg

Дата публикации:
21.08.2013
Дата изменения:
21.08.2013
Всего просмотров:
1047
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FFmpeg 2.x
Уязвимые версии: FFmpeg версии до 2.0.1

Описание:
Уязвимость позволяет злоумышленнику произвести DoS атаку.

1. Уязвимость существует из-за неизвестной ошибки. Удаленный пользователь может аварийно завершить работу приложения.

2. Уязвимость существует из-за ошибки в функции "kempf_decode_tile()" в файле libavcodec/g2meet.c. Удаленный пользователь может аварийно завершить работу приложения.

3. Уязвимость существует из-за ошибки в функции "av_reallocp_array()" в файле libavutil/mem.c. Удаленный пользователь может аварийно завершить работу приложения.

URL производителя: http://ffmpeg.org/

Решение: Установите последнюю версию 2.0.1 с сайта производителя.

Ссылки: https://github.com/FFmpeg/FFmpeg/commit/e43a0a232dbf6d3c161823c2e07c52e76227a1bc
https://github.com/FFmpeg/FFmpeg/commit/2960576378d17d71cc8dccc926352ce568b5eec1
https://github.com/FFmpeg/FFmpeg/commit/c94f9e854228e0ea00e1de8769d8d3f7cab84a55

или введите имя

CAPTCHA