Обход ограничений безопасности в Drupal Entity API

Дата публикации:
20.08.2013
Дата изменения:
20.08.2013
Всего просмотров:
1316
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Entity API Module 7.x
Уязвимые версии: Drupal Entity API версии до 7.x-1.2

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за того, что приложение не ограничивает доступ к комментариям в узле "entity_access()". Удаленный пользователь может получить доступ к закрытым комментариям.

2. Уязвимость существует из-за того, что приложение не ограничивает доступ к объектам с полями "Views " или плагином "area". Удаленный пользователь может получить доступ к закрытым объектам.

Примечание: Для успешной успешной эксплуатации уязвимости необходимо, чтобы "View" были настроены таким образом, чтобы не отображать объекты в полях, заголовках или нижнем колонтитуле.

URL производителя: https://drupal.org/project/entity

Решение: Установите обновление 7.x-1.2 с сайта производителя.

Ссылки: https://drupal.org/node/2065207

или введите имя

CAPTCHA