Множественные уязвимости в OpenEMR

Дата публикации:
16.07.2013
Дата изменения:
16.07.2013
Всего просмотров:
1471
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenEMR 4.x
Уязвимые версии: OpenEMR 4.1.1 patch-12, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "note" в сценарии /interface/main/onotes/office_comments_full.php (когда параметр "mode" равен "new"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "start" и "end" в сценарии /interface/reports/custom_report_range.php, а также в параметре "form_newid" в сценарии /custom/chart_tracker.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.oemr.org/

Решение: Установите обновление с сайта производителя.

Ссылки: http://www.open-emr.org/wiki/index.php/OpenEMR_Patches#4.1.1_Patch_.2806.2F14.2F2013.29
https://www.trustwave.com/spiderlabs/advisories/TWSL2013-018.txt

или введите имя

CAPTCHA