Множественные уязвимости в Dolibarr ERP/CRM

Дата публикации:
23.05.2013
Дата изменения:
23.05.2013
Всего просмотров:
2669
Опасность:
Высокая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:W/RC:C) = Base:5.8/Temporal:4.7
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:W/RC:C) = Base:9.3/Temporal:7.5
CVE ID:
CVE-2013-2091
CVE-2013-2093
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Dolibarr ERP/CRM 3.x
Уязвимые версии: Dolibarr ERP/CRM 3.3.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "pays" в сценарии adherents/fiche.php (когда параметр "rowid" установлен). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Для успешной эксплуатации уязвимости необходимо, чтобы модуль "Members" был активирован, а также права доступа "Read members".

2. Уязвимость существует из-за недостаточной проверки загружаемых файлов в параметре "code" в сценарии viewimage.php (когда параметр "modulepart" равен "barcode", "generator" равен "phpbarcode", а "encoding" равен "C39") в "popen()" в core/lib/barcode.lib.php. Удаленный пользователь может загрузить файл с расширением ".jpg", ".gif" или ".png", содержащий PHP код, и выполнить его на системе с привилегиями Web сервера.

Для успешной эксплуатации уязвимости необходимо, чтобы был установлен barcode generation tool.

URL производителя: http://www.dolibarr.org/

Решение: Установите обновление из GIT репозитория.

Ссылки: https://github.com/Dolibarr/dolibarr/commit/9427e32e2ed54c1a2bc519a88c057207836df489
https://github.com/Dolibarr/dolibarr/blob/526a80dd202bbca396687a502d52c27e06e97fff/htdocs/core/lib/barcode.lib.php

или введите имя

CAPTCHA