Обход ограничений безопасности в Ruby

Дата публикации:
21.05.2013
Дата изменения:
21.05.2013
Всего просмотров:
788
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:C/E:U/RL:O/RC:C) = Base:8.3/Temporal:6.1
CVE ID:
CVE-2013-2065
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby 1.9.x
Ruby 2.0.x
Уязвимые версии:
Ruby версии до 1.9.3 patchlevel 429
Ruby версии до 2.0.0 patchlevel 195

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за того, что модули DL и Fiddle не правильно проверяют уровень $SAFE при обработке определенных объектов. Удаленный пользователь может обойти ограничения безопасности.

URL производителя: http://www.ruby-lang.org/en/

Решение: Установите обновление с сайта производителя.

Ссылки: http://www.ruby-lang.org/en/news/2013/05/14/taint-bypass-dl-fiddle-cve-2013-2065/
http://www.ruby-lang.org/en/news/2013/05/14/ruby-1-9-3-p429-is-released/

или введите имя

CAPTCHA