Обход ограничений безопасности в Spree

Дата публикации:
06.03.2013
Дата изменения:
06.03.2013
Всего просмотров:
772
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:6.8/Temporal:5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Spree 1.x
Уязвимые версии: Spree 1.3.x и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за ошибки при обработке входных данных при обновлении пользователя. Удаленные пользователь может присвоить произвольную роль и, к примеру, получить привилегии администратора.

Примечание: Уязвимость позволяет административным пользователям выполнить определенные команды Ruby.

URL производителя: http://spreecommerce.com/

Решение: Установите обновление с сайта производителя.

Ссылки: http://spreecommerce.com/blog/multiple-security-vulnerabilities-fixed

или введите имя

CAPTCHA