Межсайтовый скриптинг в Apache HTTP Server

Дата публикации:
26.02.2013
Дата изменения:
26.02.2013
Всего просмотров:
1419
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2012-3499
CVE-2012-4558
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache 2.4.x
Уязвимые версии: Apache HTTP Server версии до 2.4.4.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных, связанных с именами хостов и URI в модулях mod_info, mod_ldap, mod_status, mod_imagemap и mod_proxy_ftp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в manager интерфейсе в модуле mod_proxy_balancer. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://httpd.apache.org/

Решение: Установите последнюю версию 2.4.4 с сайта производителя.

Ссылки: http://www.apache.org/dist/httpd/CHANGES_2.4.4
http://www.apache.org/dist/httpd/Announcement2.4.html

или введите имя

CAPTCHA