Межсайтовый скриптинг в WordPress Contact Form

Дата публикации:
22.02.2013
Дата изменения:
22.02.2013
Всего просмотров:
1002
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Contact Form Plugin 3.x
Уязвимые версии: WordPress Contact Form 3.34, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cntctfrm_contact_message" в сценарии index.php в wp-content/plugins/contact-form-plugin/trunk/contact_form.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/contact-form-plugin/

Решение: Установите последнюю версию 3.35 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/contact-form-plugin/changelog/
http://plugins.trac.wordpress.org/changeset/670240/contact-form-plugin/trunk

или введите имя

CAPTCHA