Отказ в обслуживании в PostgreSQL

Дата публикации:
08.02.2013
Дата изменения:
08.02.2013
Всего просмотров:
1082
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:3.3/Temporal:2.4
CVE ID:
CVE-2013-0255
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PostgreSQL 8.x
PostgreSQL 9.x
Уязвимые версии: PostgreSQL 9.2.2-1 64-bit и более ранние версии.

Описание:
Уязвимость позволяет злоумышленнику произвести DoS атаку.

Уязвимость существует из-за недостаточной обработки входных данных в функции "enum_recv()" в файле backend/utils/adt/enum.c. Удаленный пользователь может с помощью специально сформированного SQL-запроса произвести DoS атаку.

URL производителя: http://www.postgresql.org/

Решение: Установите последнюю версию 8.3.23, 8.4.16, 9.0.12, 9.1.8 или 9.2.3 с сайта производителя.

или введите имя

CAPTCHA