Множественные уязвимости в phlyMail Lite

Дата публикации:
31.01.2013
Дата изменения:
31.01.2013
Всего просмотров:
764
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:T/RC:C) = Base:5/Temporal:3.8
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phlyMail Lite 4.x
Уязвимые версии: phlyMail Lite 4.03.04, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "go" в сценарии frontend/derefer.php. Удаленный пользователь может перенаправить другого пользователя на произвольный web-сайт.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "name" и "url" в сценарии config.php (когда параметры "screen" и "module" равны "bookmarks"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости необходимо иметь административный доступ.

3. Уязвимость существует из-за недостаточной обработки входных данных в нескольких параметрах в сценарии config.php (когда параметр "action" равен "users", а "whattodo" равен "savenewuser"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.Примечание: Для успешной эксплуатации уязвимости необходимо иметь административный доступ, а также права доступа "Write" к модулю "User management".

URL производителя: http://phlymail.com/en/consumers/phlymail-lite.html

Решение: Для устранения уязвимостей №1 и №3 установите последнюю версию 4.4.0 с сайта производителя.

Ссылки: http://freecode.com/projects/phlymail/releases/351757
http://www.zeroscience.mk/en/vulnerabilities/ZSL-2013-5122.php
http://www.zeroscience.mk/en/vulnerabilities/ZSL-2013-5123.php

или введите имя

CAPTCHA