SQL-инъекция в WordPress WP Symposium

Дата публикации:
22.01.2013
Дата изменения:
22.01.2013
Всего просмотров:
1773
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP Symposium Plugin
Уязвимые версии: WordPress WP Symposium 12.09, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "uid" в сценарии index.php (когда параметр "page_id" равен идентификатору profile menu). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в нескольких параметрах в нескольких сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Пример:

http://[host]/wp-content/plugins/wp-symposium/ajax/symposium_groups_functions.php?action=get_group_members&gid
http://[host]/wp-content/plugins/wp-symposium/get_album_item.php?size
http://[host]/wp-content/plugins/wp-symposium/ajax/symposium_forum_functions.php?action=updateEditDetails&tid
http://[host]/wp-content/plugins/wp-symposium/ajax/symposium_forum_functions.php?action=updateEditDetails&topic_category
http://[host]/wp-content/plugins/wp-symposium/ajax/symposium_profile_functions.php?action=addFriend&friend_to

URL производителя: http://wordpress.org/extend/plugins/wp-symposium/

Решение: Установите последнюю версию 12.12 с сайта производителя.

или введите имя

CAPTCHA