Межсайтовый скриптинг в WordPress Answer My Question

Дата публикации:
19.09.2012
Всего просмотров:
846
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Answer My Question Plugin 1.x
Уязвимые версии: WordPress Answer My Question версии до 1.2.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "user_name" и "subject" в сценарии record_question.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/answer-my-question/

Решение: Установите последнюю версию 1.2 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/answer-my-question/changelog/
http://plugins.trac.wordpress.org/changeset/600481/answer-my-question
http://www.girlinthemiddle.net/2012/09/xss-vulnerability-in-answer-my-question.html

или введите имя

CAPTCHA