Множественные уязвимости в WordPress Shopping Cart Plugin

Дата публикации:
14.01.2013
Дата изменения:
14.01.2013
Всего просмотров:
1034
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C) = Base:7.5/Temporal:6.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Shopping Cart 8.x (plugin for WordPress)
Уязвимые версии: WordPress Shopping Cart Plugin 8.1.14, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "reqID" в различных сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Уязвимые сценарии:
wp-content/plugins/levelfourstorefront/scripts/administration/backup.php
wp-content/plugins/levelfourstorefront/scripts/administration/dbuploaderscript.php
wp-content/plugins/levelfourstorefront/scripts/administration/exportaccounts.php
wp-content/plugins/levelfourstorefront/scripts/administration/exportsubscribers.php
wp-content/plugins/levelfourstorefront/scripts/administration/emailimageuploaderscript.php
wp-content/plugins/levelfourstorefront/scripts/administration/imageuploaderscript.php
wp-content/plugins/levelfourstorefront/scripts/administration/printorder.php
wp-content/plugins/levelfourstorefront/scripts/administration/productuploaderscript.php
wp-content/plugins/levelfourstorefront/scripts/administration/swatchuploaderscript.php

URL производителя: http://wordpress.org/extend/plugins/levelfourstorefront/

Решение: Установите последнюю версию 8.1.15 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/levelfourstorefront/changelog/
http://plugins.trac.wordpress.org/changeset/648554/levelfourstorefront
http://www.opensyscom.fr/Actualites/wordpress-plugins-wordpress-shopping-cart-multiple-vulnerability.html

или введите имя

CAPTCHA