Компрометация системы в Foxit Reader

Дата публикации:
11.01.2013
Дата изменения:
18.01.2013
Всего просмотров:
2371
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:F/RL:O/RC:C) = Base:10/Temporal:8.3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Функциональный эксплоит
Уязвимые продукты:
Foxit Reader 5.x
Foxit Reader Plugin 2.x (extension for Firefox)
Уязвимые версии:
Foxit Reader 5.4.4.1128, возможно другие версии
Foxit Reader Plugin 2.2.1.530, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе. Уязвимость существует из-за ошибки проверки границ данных в плагине Foxit Reader для браузеров (npFoxitReaderPlugin.dll) при обработке URL. Удаленный пользователь может с помощью специально сформированного URL адреса вызвать переполнение буфера в стеке и выполнить произвольный код на целевой системе.

URL производителя: http://www.foxitsoftware.com/

Решение: Для устранения уязвимости установите продукт версии 5.4.5 с сайта производителя.

Ссылки: http://retrogod.altervista.org/9sg_foxit_overflow.htm
Журнал изменений:
18.01.2013
Внесено изменение в раздел "Решение",

или введите имя

CAPTCHA