Межсайтовый скриптинг в WordPress Welcart e-Commerce

Дата публикации:
18.12.2012
Дата изменения:
18.12.2012
Всего просмотров:
752
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2012-5177
CVE-2012-5178
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Welcart e-Commerce Plugin 1.x
Уязвимые версии: WordPress Welcart e-Commerce 1.2.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за неопределенной ошибки при обработке входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение.

URL производителя: http://www.welcart.com/

Решение: Установите последнюю версию 1.2.2 с сайта производителя.

Ссылки: http://www.welcart.com/community/archives/4524
http://jvn.jp/en/jp/JVN18731696/index.html
http://jvn.jp/en/jp/JVN53269985/index.html
http://jvndb.jvn.jp/en/contents/2012/JVNDB-2012-000108.html
http://jvndb.jvn.jp/en/contents/2012/JVNDB-2012-000109.html

или введите имя

CAPTCHA