Межсайтовый скриптинг в WordPress Buddystream

Дата публикации:
15.11.2012
Дата изменения:
15.11.2012
Всего просмотров:
641
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress BuddyStream Plugin 2.x
Уязвимые версии: WordPress Buddystream 2.6.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "content" в сценарии wp-content/plugins/buddystream/extensions/default/templates/ShareBox.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "link" в сценарии wp-content/plugins/buddystream/extensions/default/templates/ShareBox.php (когда параметр "share" равен "linkedin"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/buddystream/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA