Множественные уязвимости в WordPress Cloudsafe365

Дата публикации:
31.08.2012
Дата изменения:
31.08.2012
Всего просмотров:
984
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:ND/RL:O/RC:C) = Base:4.3/Temporal:0
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:ND/RL:O/RC:C) = Base:5/Temporal:0
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Cloudsafe365 Plugin 1.x
Уязвимые версии: WordPress Cloudsafe365 1.46, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "file", "line" и "malware" в сценарии wp-content/plugins/cloudsafe365-for-wp/admin/editor/cs365_edit.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "file" в сценарии wp-content/plugins/cloudsafe365-for-wp/admin/editor/cs365_edit.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

Решение: Установите последнюю версию 1.47 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/cloudsafe365-for-wp/changelog/
http://archives.neohapsis.com/archives/fulldisclosure/current/0327.html

или введите имя

CAPTCHA