Множественные уязвимости в Apache Struts

Дата публикации:
31.08.2012
Дата изменения:
31.08.2012
Всего просмотров:
1075
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:ND/RL:O/RC:C) = Base:4.3/Temporal:0
(AV:N/AC:L/Au:N/C:N/I:N/A:C/E:ND/RL:O/RC:C) = Base:7.8/Temporal:0
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache Struts 2.x
Уязвимые версии: Apache Struts версии до 2.3.4.1.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах маркера. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки при обработке запроса параметров. Удаленный пользователь может исчерпать ресурсы процессора и вызвать отказ в обслуживании.

URL производителя: http://struts.apache.org/

Решение: Установите последнюю версию 2.3.4.1 с сайта производителя.

Ссылки: http://struts.apache.org/2.x/docs/s2-010.html
http://struts.apache.org/2.x/docs/s2-011.html

или введите имя

CAPTCHA