Межсайтовый скриптинг в ConcourseSuite

Дата публикации:
08.08.2012
Дата изменения:
08.08.2012
Всего просмотров:
581
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ConcourseSuite 6.x
Уязвимые версии: ConcourseSuite 6.1 (20120209), возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и изменить права доступа пользователей.

2. Уязвимость существует из-за недостаточной обработки входных данных в нескольких параметрах в нескольких сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Пример:

http:///crm/Sales.do?nameFirst&nameLast
http:///crm/ExternalContacts.do?nameFirst&nameLast&company
http:///crm/Accounts.do?name
http:///crm/MyCFSProfile.do?address1state

URL производителя: http://www.concursive.com/show/concoursesuite

Решение: Установите последнюю версию 6.2 (20120806) с сайта производителя.

Ссылки: https://www.concursive.com/show/concoursesuite-support/wiki/SA-CORE-2012-001

или введите имя

CAPTCHA