Множественные уязвимости в Kerberos

Дата публикации:
02.08.2012
Дата изменения:
02.08.2012
Всего просмотров:
1781
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:P/RL:O/RC:C) = Base:9.3/Temporal:7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:C/E:P/RL:O/RC:C) = Base:9/Temporal:7
CVE ID:
CVE-2012-1014
CVE-2012-1015
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Kerberos 5.x
Уязвимые версии: Kerberos 5.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки в функции kdc_handle_protected_negotiation() которая при создании контрольных сумм некорректно проверяет тип ключа. Удаленный пользователь может с помощью специально сформированного AS-REQ освободить неинициализированный обработчик и выполнить произвольный код на целевой системе.

Примечание: Уязвимость распространяется только на krb5-1.8 и более поздние версии продукта.

2. Уязвимость существует из-за разыменования нулевого указателя в функции finish_process_as_req(). Удаленный пользователь может с помощью специально сформированного AS-REQ вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: http://web.mit.edu/kerberos/www/

Решение: Для устранения уязвимости установите исправление с сайта производителя.

Ссылки: http://web.mit.edu/kerberos/www/advisories/MITKRB5-SA-2012-001.txt

или введите имя

CAPTCHA