Межсайтовый скриптинг в WordPress Mac Photo Gallery

Дата публикации:
25.07.2012
Дата изменения:
25.07.2012
Всего просмотров:
889
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Mac Photo Gallery Plugin 2.x
Уязвимые версии: WordPress Mac Photo Gallery 2.10, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в нескольких параметрах в двух сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Пример:

http://[host]/wp-content/plugins/mac-dock-gallery/macalbajax.php?macPhoto_desc
http://[host]/wp-content/plugins/mac-dock-gallery/macalbajax.php?macedit_name&macedit_desc
http://[host]/wp-content/plugins/mac-dock-gallery/macphtajax.php?macPhoto_name
http://[host]/wp-content/plugins/mac-dock-gallery/macphtajax.php?macAlbum_name&macAlbum_desc

URL производителя: http://wordpress.org/extend/plugins/mac-dock-gallery/

Решение: Установите последнюю версию 3.0 с сайта производителя.

Ссылки: http://plugins.trac.wordpress.org/changeset/571182/mac-dock-gallery

или введите имя

CAPTCHA