Межсайтовый скриптинг в WordPress Quick Post Widget

Дата публикации:
10.07.2012
Дата изменения:
10.07.2012
Всего просмотров:
716
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Quick Post Widget 1.x
Уязвимые версии: WordPress Quick Post Widget 1.9.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "quick_post_title", "quick_post_content" и "quick_post_new_cat" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и опубликовать быстрый пост.

URL производителя: http://qpw.famvanakkeren.nl/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.darksecurity.de/index.php?/218-SSCHADV2012-016-WordPress-Plugin-Quick-Post-Widget-1.9.1-Multiple-XSS-vulnerabilities.html

или введите имя

CAPTCHA