Межсайтовый скриптинг в Nagios XI

Дата публикации:
18.06.2012
Дата изменения:
18.06.2012
Всего просмотров:
929
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Nagios XI 2011.x
Уязвимые версии: Nagios XI версии до 2011r3.0.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "div" в сценарии includes/components/graphexplorer/visApi.php, а также в параметре "view" в сценарии nagiosxi/perfgraphs/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://nagios.com/

Решение: Установите последнюю версию 2011r3.0 с сайта производителя.

Ссылки: http://0a29.blogspot.dk/2012/06/0a29-12-1-cross-site-scripting.html
http://assets.nagios.com/downloads/nagiosxi/CHANGES-2011.TXT

или введите имя

CAPTCHA