SQL-инъекция в Contao

Дата публикации:
15.06.2012
Дата изменения:
15.06.2012
Всего просмотров:
1563
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Contao 2.x
Уязвимые версии: Contao 2.11.3, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "field" в сценарии system/modules/backend/Ajax.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.contao.org/en/

Решение: Установите последнюю версию 2.11.4 с сайта производителя.

Ссылки: http://www.contao.org/en/changelog/auto_item/changelog/versions/2.11.html
https://github.com/contao/core/issues/4427

или введите имя

CAPTCHA