Множественные уязвимости в Apache CXF

Дата публикации:
14.06.2012
Дата изменения:
14.06.2012
Всего просмотров:
1481
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
(AV:N/AC:M/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:6.8/Temporal:5
CVE ID:
CVE-2012-2378
CVE-2012-2379
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache CXF 2.x
Уязвимые версии: Apache CXF 2.x

Описание:
Уязвимость позволяет злоумышленнику обойти ограничения безопасности на системе.

1. Уязвимость существует из-за ошибки при использовании Supporting Token для подписи или шифрования некоторых частей или элементов. Определенные дочерние политики утверждений политик WS -SecurityPolicy 1.1 SupportingToken могут быть приняты клиентской частью.

Примечание: Уязвимость № 1 распространяется на версии 2.4.5 -- 2.4.7, 2.5.1 - 2.5.3 и 2.6.0.

2. Уязвимость существует из-за ошибки при определении процессов WS-SecurityPolicy 1.1 и 1.2 как дочерних к Supporting Token. Удаленный пользователь может вызвать некорректную проверку подписи или шифрования определенным токеном.

URL производителя: http://apache.org/

Решение: Для устранения уязвимостей установите продукт версии 2.4.8, 2.5.4, или 2.6.1 с сайта производителя.

Ссылки: http://cxf.apache.org/cve-2012-2378.html
http://cxf.apache.org/cve-2012-2379.html

или введите имя

CAPTCHA