Компрометация системы в WordPress VideoWhisper Video Presentation

Дата публикации:
07.06.2012
Дата изменения:
07.06.2012
Всего просмотров:
1480
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C) = Base:9.3/Temporal:7.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress VideoWhisper Video Presentation Plugin 3.x
Уязвимые версии: WordPress VideoWhisper Video Presentation 3.17, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной проверки загружаемых файлов в сценарии wp-content/plugins/videowhisper-video-presentation/vp/vw_upload.php. Удаленный пользователь может загрузить файл с расширением ".gif", содержащий PHP код, и выполнить его на системе с привилегиями Web сервера.

Для успешной эксплуатации уязвимости требуется, чтобы Apache небыл настроен на обработку медиа типов файлов для файлов с расширением ".gif".

URL производителя: http://wordpress.org/extend/plugins/videowhisper-video-presentation/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.opensyscom.fr/Actualites/wordpress-plugins-videowhisper-video-presentation-shell-upload-vulnerability.html

или введите имя

CAPTCHA