Множественные уязвимости в WordPress Google Maps Via Store Locator Plus

Дата публикации:
07.06.2012
Дата изменения:
07.06.2012
Всего просмотров:
1171
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:U/RC:C) = Base:5/Temporal:4.3
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:U/RC:C) = Base:6.4/Temporal:5.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Google Maps Via Store Locator Plus Plugin 3.x
Уязвимые версии: WordPress Google Maps Via Store Locator Plus 3.0.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за ошибки при отображении пути установки в сценарии wp-content/plugins/store-locator-le/core/load_wp_config.php. Удаленный пользователь может раскрыть путь установки.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "query" в сценарии /wp-content/plugins/store-locator-le/downloadcsv.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://wordpress.org/extend/plugins/store-locator-le/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://packetstormsecurity.org/files/113276/WordPress-Google-Maps-Via-Store-Locator-Plus-Email-Spool-SQL-Injection.html

или введите имя

CAPTCHA