Межсайтовый скриптинг в Drupal Search API

Дата публикации:
25.05.2012
Дата изменения:
25.05.2012
Всего просмотров:
946
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Search API Module 7.x
Уязвимые версии: Drupal Search API версии до 7.x-1.1

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных при генерации исключений или регистрации ошибки. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости необходимо, чтобы пользователи могли вручную ввести идентификаторы полей.

URL производителя: http://drupal.org/project/search_api

Решение: Установите последнюю версию 7.x-1.1 с сайта производителя.

Ссылки: http://drupal.org/node/1597364

или введите имя

CAPTCHA