Множественные уязвимости в Joomla! JCE

Дата публикации:
22.05.2012
Дата изменения:
22.05.2012
Всего просмотров:
3059
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
JCE 2.x (component for Joomla!)
Уязвимые версии: Joomla! JCE 2.1.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "search" в сценарии administrator/index.php (когда параметр "option" равен "com_jce", а "view" равен "users"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии components/com_jce/editor/extensions/browser/file.php при проверке запросов переименования файлов. Удаленный пользователь может переименовать конфигурационные файлы ядра Joomla! и сделать приложение недоступным.

Примечание: Для успешной эксплуатации уязвимости необходимо иметь привилегии "Author".

URL производителя: http://www.joomlacontenteditor.net/

Решение: Установите последнюю версию 2.1.3 с сайта производителя.

Ссылки: http://www.joomlacontenteditor.net/news/item/jce-213-released?category_id=32
http://secunia.com/secunia_research/2012-16/
http://secunia.com/secunia_research/2012-17/

или введите имя

CAPTCHA