Межсайтовый скриптинг в WordPress Subscribe2

Дата публикации:
17.05.2012
Дата изменения:
17.05.2012
Всего просмотров:
1222
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Subscribe2 Plugin 8.x
Уязвимые версии: Subscribe2 дополнение для WordPress 8.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "subject" в сценарии wp-admin/admin.php (когда параметр "page" равен "s2_posts") в wp-content/plugins/subscribe2/admin/send_email.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "searchterm" в сценарии wp-admin/admin.php (когда параметр "page" равен "s2_tools"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/subscribe2/

Решение: Установите последнюю версию 8.2 с сайта производителя.

Ссылки: http://packetstormsecurity.org/files/112688/WordPress-Subscribe2-8.0-Cross-Site-Scripting.html
http://wordpress.org/extend/plugins/subscribe2/changelog/

или введите имя

CAPTCHA