Межсайтовый скриптинг в WordPress CodeStyling Localization

Дата публикации:
16.05.2012
Дата изменения:
16.05.2012
Всего просмотров:
1594
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress CodeStyling Localization 1.x
Уязвимые версии: CodeStyling Localization дополнение для WordPress 1.99.17, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "name" в сценарии wp-admin/admin-ajax.php в wp-content/plugins/codestyling-localization/codestyling-localization.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/codestyling-localization/

Решение: Способов устранения уязвимости не существует в настоящее время.



Ссылки: http://packetstormsecurity.org/files/112709/WordPress-CodeStyling-Localization-1.99.16-Cross-Site-Scripting.html
или введите имя

CAPTCHA