Повышение привилегий в Ruby

Дата публикации:
21.02.2011
Всего просмотров:
506
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:H/Au:N/C:N/I:C/A:C/E:U/RL:O/RC:C) = Base:5.6/Temporal:4.1
CVE ID:
CVE-2011-1004
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby 1.8.x
Ruby 1.9.x
Уязвимые версии:
Ruby 1.8.6 patchlevel 420 и более ранние версии
Ruby 1.8.7 patchlevel 330 и более ранние версии
Ruby 1.9.1 patchlevel 430 и более ранние версии
Ruby 1.9.2 patchlevel 136 и более ранние версии

Описание:
Уязвимость позволяет пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки состояния операции в методе FileUtils.remove_entry_secure. Удаленный пользователь может с помощью специально сформированной символической ссылки удалить произвольный каталог и файл.

URL производителя: http://www.ruby-lang.org/en/

Решение: Для устранения уязвимости установите продукт версии 1.8.7-334, 1.9.1-p431 или 1.9.2-p180 с сайта производителя.

Ссылки: http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

или введите имя

CAPTCHA