Межсайтовый скриптинг в WordPress User Photo

Дата публикации:
11.05.2012
Дата изменения:
11.05.2012
Всего просмотров:
946
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress User Photo Plugin 0.x
Уязвимые версии: WordPress User Photo 0.9.5.1 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии wp-admin/options-general.php в функции "userphoto_options_page()" в wp-content/plugins/user-photo/user-photo.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/user-photo/

Решение: Установите последнюю версию 0.9.5.2 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/user-photo/changelog/

или введите имя

CAPTCHA