Межсайтовый скриптинг в TWiki

Дата публикации:
14.10.2010
Всего просмотров:
850
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2010-3841
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TWiki
Уязвимые версии: TWiki версии до 5.0.1

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "rev" в сценарии bin/view в bin/login. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.twiki.org/

Решение: Установите последнюю версию 5.0.1 с сайта производителя.

Ссылки: http://twiki.org/cgi-bin/view/Codev/SecurityAlert-CVE-2010-3841

или введите имя

CAPTCHA