Межсайтовый скриптинг в Piwigo

Дата публикации:
26.04.2012
Дата изменения:
26.04.2012
Всего просмотров:
1122
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2012-2208
CVE-2012-2209
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Piwigo 2.x
Уязвимые версии: Piwigo 2.3.3, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "section" в сценарии (когда параметр "page" равен "configuration"), в параметре "installstatus" (когда параметр "page" равен "languages_new"), а также в параметре "theme" (когда параметр "page" равен "theme"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://piwigo.org/

Решение: Установите последнюю версию 2.3.4 с сайта производителя.

Ссылки: https://www.htbridge.com/advisory/HTB23085
http://piwigo.org/bugs/view.php?id=2607
http://piwigo.org/releases/2.3.4
http://piwigo.org/forum/viewtopic.php?id=19173

или введите имя

CAPTCHA