Множественные уязвимости в Exponent CMS

Дата публикации:
24.04.2012
Дата изменения:
24.04.2012
Всего просмотров:
708
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Exponent CMS 2.x
Уязвимые версии: Exponent CMS 2.0.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "tag" в сценарии index.php (когда параметр "action" равен "showall_by_tags"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "section" в сценарии index.php в функции "getSection()" в framework/core/subsystems/expRouter.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.exponentcms.org/

Решение: Установите последнюю версию 2.0.6 с сайта производителя.

Ссылки: http://www.mavitunasecurity.com/blog/xss-and-blind-sql-injection-vulnerabilities-in-exponentcms/
http://exponentcms.org/news/-happy-hyperbole-v2-0-6-is-in-full-bloom

или введите имя

CAPTCHA