Межсайтовый скриптинг в WordPress WP Survey And Quiz Tool

Дата публикации:
23.04.2012
Дата изменения:
23.04.2012
Всего просмотров:
2018
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP Survey And Quiz Tool Plugin 1.x
Уязвимые версии: WP Survey And Quiz Tool дополнение для WordPress 2.9.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "rowcount" в сценариях wp-content/plugins/wp-survey-and-quiz-tool/javascript/question_form.php, wp-content/plugins/wp-survey-and-quiz-tool/javascript/quiz_section.php, wp-content/plugins/wp-survey-and-quiz-tool/javascript/shared_form.php, wp-content/plugins/wp-survey-and-quiz-tool/javascript/survey_question.php и wp-content/plugins/wp-survey-and-quiz-tool/javascript/survey_section.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/wp-survey-and-quiz-tool/

Решение: Установите последнюю версию 2.9.3 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/wp-survey-and-quiz-tool/changelog/
http://plugins.trac.wordpress.org/changeset?reponame=&new=534120%40wp-survey-and-quiz-tool&old=526712%40wp-survey-and-quiz-tool

или введите имя

CAPTCHA