Межсайтовый скриптинг в The Bug Genie

Дата публикации:
17.11.2010
Всего просмотров:
886
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
The Bug Genie 2.x
Уязвимые версии: The Bug Genie 2.1.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "scope" в сценариях index.php, modules/search/search.php, или modules/search/search_stripped.php в include/classes/BUGSscope.class.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и изменить пароль или удалить учетную запись пользователя.

URL производителя: http://www.thebuggenie.com/

Решение: Установите последнюю версию 2.1.2 с сайта производителя.

Ссылки: http://www.thebuggenie.com/b2/modules/publish/articles.php?article_id=82
http://holisticinfosec.org/content/view/161/45/

или введите имя

CAPTCHA