Межсайтовый скриптинг в SAP NetWeaver

Дата публикации:
17.11.2010
Всего просмотров:
744
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAP NetWeaver 7.x
Уязвимые версии: SAP NetWeaver ECC 6.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "connid" в сценарии OpenSQLMonitors/servlet/ConnectionMonitorServlet. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "reqTableColumns" в сценарии OpenSQLMonitors/servlet/CatalogBufferMonitorServlet. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://scn.sap.com/community/netweaver/content?filterID=content~objecttype~objecttype%5bdocument%5d

Решение: Установите обновление с сайта производителя.

Ссылки: https://service.sap.com/sap/support/notes/1391770
http://dsecrg.com/pages/vul/show.php?id=156

или введите имя

CAPTCHA