Межсайтовый скриптинг в WordPress SH Slideshow

Дата публикации:
16.04.2012
Дата изменения:
16.04.2012
Всего просмотров:
1157
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress SH Slideshow Plugin 3.x
Уязвимые версии: SH Slideshow дополнение для WordPress 3.1.7, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "src" в сценарии wp-content/plugins/sh-slideshow/timthumb.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Подробное описание уязвимости смотрите здесь:
http://www.securitylab.ru/vulnerability/407455.php

URL производителя: http://wordpress.org/extend/plugins/sh-slideshow/

Решение: Установите последнюю версию 3.1.8 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/sh-slideshow/changelog/

или введите имя

CAPTCHA