Межсайтовый скриптинг в GIT

Дата публикации:
16.12.2010
Всего просмотров:
756
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2010-3906
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GIT 1.x
Уязвимые версии: GIT версии до 1.7.3.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "f" и "fp" в интерфейсе "gitweb" в сценарии gitweb/gitweb.perl. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.kernel.org/pub/software/scm/git/docs/

Решение: Установите последнюю версию 1.7.3.4 с сайта производителя.

Ссылки: http://git.kernel.org/?p=git/git.git;a=blob;f=Documentation/RelNotes/1.7.3.4.txt
http://git.kernel.org/?p=git/git.git;a=commit;h=3017ed62f47ce14a959e2d315c434d4980cf4243

или введите имя

CAPTCHA