Межсайтовый скриптинг в ZyXEL GS1510

Дата публикации:
30.03.2012
Дата изменения:
30.03.2012
Всего просмотров:
857
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ZyXEL GS1510
Уязвимые версии: ZyXEL GS1510 V1.00(BVN.1), возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за того, что приложение хранит учетные данные в webctrl.cgi, а также в значениях куки файлов в не зашифрованном виде. Удаленный пользователь может перехватить учетные данные с помощью MITM атаки.

2. Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии images. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.zyxel.com/dk/da/products_services/gs1510_series.shtml

Решение: Установите последнюю версию V1.00(BVN.1)C0 с сайта производителя.

Ссылки: https://www.upsploit.com/index.php/advisories/view/UPS-2011-0042

или введите имя

CAPTCHA