Межсайтовый скриптинг в SAP NetWeaver

Дата публикации:
14.03.2011
Всего просмотров:
731
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
4
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAP NetWeaver 7.x
Уязвимые версии: SAP NetWeaver 7.х, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за неизвестной ошибки при обработке входных данных в XI SOAP Adapter (com.sap.aii.af.soapadapter). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "logonUrl" на странице авторизации BSP (/sap/bc/public/bsp/sap/system_public/logon.htm). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "fileNameL" и "directoryNameL" в сервлетах CheckService и ExportabilityCheck, в параметре "XiDynPage_ThreadId" в сервлете ViewCaches, в параметрах "thread", "invert" и "filter" в сервлете ShowMemLog, в параметре "id" в сценарии error_msg.jsp, а также в параметре "refresh" в сценарии ViewCaches.jsp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "logger" в сценарии ViewLogger.jsp, а также в параметре "class" в сервлете ShowMemLog. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://scn.sap.com/community/netweaver/blog/2011/06/07/sap-netweaver-73-now-generally-available

Решение: Установите обновление с сайта производителя.

Ссылки: https://service.sap.com/sap/support/notes/1438191
https://service.sap.com/sap/support/notes/1450270
https://service.sap.com/sap/support/notes/1512776
http://dsecrg.com/pages/vul/show.php?id=309
http://dsecrg.com/pages/vul/show.php?id=310
http://dsecrg.com/pages/vul/show.php?id=312
http://dsecrg.com/pages/vul/show.php?id=313

или введите имя

CAPTCHA