Множественные уязвимости в OpenEMR

Дата публикации:
04.04.2011
Всего просмотров:
735
Опасность:
Средняя
Наличие исправления:
Частично
Количество уязвимостей:
6
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:4.3/Temporal:3.3
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:T/RC:C) = Base:6.4/Temporal:4.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenEMR 4.x
Уязвимые версии: , возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "src_form" и "section_value" в сценарии gacl/admin/object_search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "site" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, подключить произвольные файлы из локальных источников.

Примечание: Для успешной эксплуатации уязвимости необходимо, чтобы параметр "magic_quotes_gpc" был отключен.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "tplview", "pc_category" и "pc_topic" в сценарии interface/main/calendar/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "noteid" (когда параметр "task" равен "add") в сценарии interface/main/messages/messages.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

5. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "sortby", "sortorder" и "begin" в сценарии interface/main/messages/messages.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

6. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "sortby", "sortorder" и "begin" в сценарии interface/main/messages/messages.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.oemr.org/

Решение: Установите последнюю версию 4.1.0, исправляющую уязвимости 1 и 2, с сайта производителя.

Ссылки: http://www.autosectools.com/Advisories/OpenEMR.4.0.0_Local.File.Inclusion_166.html
http://www.autosectools.com/Advisories/OpenEMR.4.0.0_Reflected.Cross-site.Scripting_164.html
http://packetstormsecurity.org/files/view/103810/openemr-xss.txt

или введите имя

CAPTCHA